Upgraded to WordPress 2.0.1 and bugs!


I upgraded to WordPress 2.0.1 today and was plagued with erratic bugs all the way. I was almost tempted to throw in the towel and migrate to another software or just give up managing my own blogging site when I found the solution.

Anyway here’s the problem:

1. When I upgraded from 1.5 to 2.0.1 there I was faced with this mind-blowing piece of error:

Warning: Invalid argument supplied for foreach() in …/public_html/wp-includes/capabilities.php on line 19

After some googling and desk-banging and trying various things, I managed to change line 19 to :

foreach ((array)$this->roles as $role => $data) {

and this apparently worked. Only thing was, I was now faced with another bug:

"You do not have sufficient permissions to access this page."

After more desk-banging and more cussing, I changed the .htaccess file and added these in:

php_flag magic_quotes_gpc off
php_flag magic_quotes_runtime off

Apparently now it works, but the solution was totally unintuitive. Food for thought. Maybe I should really have gone and use blogger.com instead.

Hm.

Advertisements